You might experience delay on transfer
Resolved·Full outage

Our banking partner has resolved the issue and everything is up and running again.

Fri, Nov 17, 2023, 11:09 AM
(1 year ago)
·
Affected components
Updates

Resolved

Our banking partner has resolved the issue and everything is up and running again.

Fri, Nov 17, 2023, 11:09 AM

Identified

Our bank central has successfully identified the issue and is actively working on a solution.

Fri, Nov 17, 2023, 08:51 AM(2 hours earlier)

Investigating

We are continuing to investigate this issue.

Fri, Nov 17, 2023, 07:51 AM(59 minutes earlier)

Investigating

We are currently experiencing issues with our banking central; therefore, you may experience delays on incoming transfers. We are currently investigating this issue.

Fri, Nov 17, 2023, 06:20 AM(1 hour earlier)
Powered by