Crypto via Lunar Block is having issues
Resolved·Full outage

You are now able to use Lunar Block again. The issue have been resolved.

Thu, Aug 18, 2022, 12:24 PM
(2 years ago)
·
Affected components
Updates

Resolved

You are now able to use Lunar Block again. The issue have been resolved.

Thu, Aug 18, 2022, 12:24 PM

Investigating

Crypto via Lunar Block is currently not working. We are investigating. We will keep you posted.

Thu, Aug 18, 2022, 12:00 PM(24 minutes earlier)
Powered by