Transfers are delayed 😒
Incident Report for Lunar
Resolved
This incident has been resolved.
Posted Jul 30, 2022 - 06:55 CEST
Investigating
We are currently experiencing delays with receiving and sending payments.

We're sorry for the inconvenience, and we'll keep posting information on this site.
Posted Jul 29, 2022 - 19:34 CEST
This incident affected: πŸ’Έ Transfers (πŸ‡©πŸ‡° Danish transfers, πŸ‡ΈπŸ‡ͺ Swedish transfers, πŸ‡³πŸ‡΄ Norwegian transfers).