Adding new cards to Apple Pay is down 🀯
Resolved

Incident is resolved.

Tue, May 31, 2022, 11:12β€―AM
(2 years ago)
Β·
Affected components

No components marked as affected

Updates

Resolved

Incident is resolved.

Tue, May 31, 2022, 11:12β€―AM

Investigating

We are currently experiencing some challenges with adding cards to Apple Pay. πŸ’ΈWe're sorry for the inconvenience, and we'll keep posting information on this site.

Tue, May 31, 2022, 10:11β€―AM(1 hour earlier)
Powered by