Issues with interests
Incident Report for Lunar
Resolved
Incident has been resolved.
Posted Jun 03, 2022 - 17:16 CEST
Identified
We have identified the problem and are currently working on resolving it. You may still experience issues with interests. We will update when we have more information.
Posted Jun 02, 2022 - 16:25 CEST
Investigating
We are currently experiencing some challenges with bank central and interests. 💸
We're sorry for the inconvenience, and we'll keep posting information on this site
Posted Jun 01, 2022 - 16:17 CEST