Report a problem
Subscribe to updates
Report a problem
Subscribe to updates
We are currently experiencing problems with MitID
Resolved
·
Degraded performance
This incident has been resolved.
Thu, Dec 15, 2022, 04:16 PM
(
2
years ago)
·
View all updates
Affected components
Dec 15, 2022, 10:32 AM
04:16 PM
📱Platform
2 affected components
💸 Transfers
1 affected component
📈 Invest
1 affected component
💲Crypto
1 affected component
🔗 Connect bank
1 affected component
Updates
Resolved
This incident has been resolved.
Thu, Dec 15, 2022, 04:16 PM
Monitoring
We are Investigating the problem
Thu, Dec 15, 2022, 10:32 AM
(
5
hours earlier)
Powered by