Card issues
Resolved·Full outage

This incident have now been resolved

Wed, Feb 16, 2022, 06:13 PM
(3 years ago)
·
Affected components
Updates

Resolved

This incident have now been resolved

Wed, Feb 16, 2022, 06:13 PM

Investigating

We are still investigating the issue and working hard on resolving it

Wed, Feb 16, 2022, 05:01 PM(1 hour earlier)

Investigating

We are experiencing technical difficulties with the Lunar VISA card and are currently investigating this issue.

Wed, Feb 16, 2022, 03:51 PM(1 hour earlier)
Powered by