Report a problem
Subscribe to updates
Report a problem
Subscribe to updates
Instabilities with Card order service
Resolved
·
Degraded performance
This incident has been resolved.
Mon, Nov 20, 2023, 08:23 PM
(
1
year ago)
·
View all updates
Affected components
Nov 20, 2023, 05:09 PM
08:23 PM
💳 Cards
1 affected component
Updates
Resolved
This incident has been resolved.
Mon, Nov 20, 2023, 08:23 PM
Investigating
We are currently investigating the issue.
Mon, Nov 20, 2023, 05:09 PM
(
3
hours earlier)
Powered by