Top-up is experiencing some issues
Resolved·Degraded performance

The issue has been resolved. Thanks for your patience.

Fri, Sep 16, 2022, 03:44 PM
(2 years ago)
·
Affected components
Updates

Resolved

The issue has been resolved. Thanks for your patience.

Fri, Sep 16, 2022, 03:44 PM

Investigating

We are currently experiencing some challenges with top-ups, which makes them unavailable at the moment. 💸

We're sorry for the inconvenience, and we'll keep posting information on this site

Fri, Sep 16, 2022, 02:11 PM(1 hour earlier)
Powered by