NemID is experiencing problems πŸ”’
ResolvedΒ·Partial outage

Nets have resolved the issue and NemID are working again. If you still have issues please try MitID.Thanks for your patience.

Sat, Jun 25, 2022, 09:25β€―PM
(2 years ago)
Β·
Affected components
Updates

Resolved

Nets have resolved the issue and NemID are working again. If you still have issues please try MitID.Thanks for your patience.

Sat, Jun 25, 2022, 09:25β€―PM

Monitoring

We are continuing to monitor for any further issues.

Fri, Jun 24, 2022, 01:13β€―PM(1 day earlier)

Monitoring

Nets is still working on a solution. You may still experience issues with NemID when trying to signup for a new account, login to the app or make a transfer. You can try to use MitID instead.

We will continue to update this page with new information as it becomes available.

Fri, Jun 24, 2022, 12:30β€―PM(42 minutes earlier)

Monitoring

Nets is still working on a solution. You may still experience issues with NemID when trying to signup for a new account, login to the app or make a transfer. You can try to use MitID instead.

We will continue to update this page with new information as it becomes available.

Thu, Jun 23, 2022, 10:34β€―AM(1 day earlier)

Monitoring

Nets have identified the issue and are working on a resolution. You may experience issues with NemID when trying to login to the app or make a transfer. You can try to use MitID instead.We will continue to update this page with new information as it becomes available.

Thu, Jun 23, 2022, 08:26β€―AM(2 hours earlier)
Powered by