We are currently experiencing issues using cards
Resolved·Full outage

We have successfully resolved the issues, and customers will no longer experience card declines.

We apologize for any inconvenience this may have caused.

Thu, Jan 4, 2024, 12:13 PM
(1 year ago)
·
Affected components
Updates

Resolved

We have successfully resolved the issues, and customers will no longer experience card declines.

We apologize for any inconvenience this may have caused.

Thu, Jan 4, 2024, 12:13 PM

Identified

We are continuing to work on a fix for this issue.

Thu, Jan 4, 2024, 11:45 AM(27 minutes earlier)

Identified

Several customers are currently experiencing their cards being declined even though there is money in their accounts. We are aware of the issue and are working to resolve it as quickly as possible

Thu, Jan 4, 2024, 11:30 AM(14 minutes earlier)
Powered by