Adding new cards to Apple Pay is down 🤯
Incident Report for Lunar
Resolved
The issue is resolved
Posted May 31, 2022 - 11:30 CEST
Investigating
We are currently experiencing some challenges with adding cards to Apple Pay. 💸
We're sorry for the inconvenience, and we'll keep posting information on this site.
Posted May 31, 2022 - 09:06 CEST