πŸ“ž Phone System is currently down πŸ“ž
Incident Report for Lunar
Resolved
This incident has been resolved.
Posted Oct 04, 2023 - 17:10 CEST
Update
We are continuing to work on a fix for this issue.
Posted Oct 04, 2023 - 17:09 CEST
Identified
The issue has been identified and we are working on a fix within the next 30 min.
Posted Oct 04, 2023 - 16:59 CEST
This incident affected: πŸ§‘β€πŸš€ Customer support (☎️ Phone).