Delays in international transfers
Incident Report for Lunar
Resolved
We are now back up and running with normal operations.

Thank you for your patience.

Over and out. Have an awesome week πŸš€
Posted Jul 04, 2022 - 09:25 CEST
Investigating
We are currently seeing some trouble with international transfers.

You can expect some delay in the processing of incoming international transfers.

We are working as hard as we can to get back up to speed, but please have patience πŸ™πŸ»
Posted Jul 01, 2022 - 15:31 CEST
This incident affected: πŸ’Έ Transfers (πŸ‡©πŸ‡° Danish transfers, πŸ‡ΈπŸ‡ͺ Swedish transfers, πŸ‡³πŸ‡΄ Norwegian transfers).