Problems with Invest
Resolved·Full outage

This incident has been resolved.

Sat, Sep 16, 2023, 09:28 AM
(1 year ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Sat, Sep 16, 2023, 09:28 AM

Investigating

We are continuing to investigate this issue.

Sat, Sep 16, 2023, 08:47 AM(40 minutes earlier)

Investigating

We are currently experiencing an issue with displaying customer balances in our investment accounts.

Rest assured, we are diligently investigating this matter and will provide you with regular updates on its resolution.

Sat, Sep 16, 2023, 08:44 AM
Powered by