Card payments are experiencing issues
ResolvedΒ·Partial outage

YAY! Everything is back to normal πŸ‘

Thu, Feb 24, 2022, 10:19β€―AM
(3 years ago)
Β·
Affected components
Updates

Resolved

YAY! Everything is back to normal πŸ‘

Thu, Feb 24, 2022, 10:19β€―AM

Investigating

We are experiencing technical difficulties with the Lunar VISA card and are currently investigating this issue. 😒

Thu, Feb 24, 2022, 10:06β€―AM(12 minutes earlier)
Powered by