Transfers are having issues 😒
ResolvedΒ·Degraded performance

Issue is resolved.

Thu, Jun 30, 2022, 07:11β€―PM
(2 years ago)
Β·
Affected components
Updates

Resolved

Issue is resolved.

Thu, Jun 30, 2022, 07:11β€―PM

Investigating

We are currently experiencing some challenges with transfers. You can also expect a small delay with receiving and sending payments.We're sorry for the inconvenience, and we'll keep posting information on this site.

Thu, Jun 30, 2022, 05:51β€―PM(1 hour earlier)
Powered by