Transfers are having issues 😢
Incident Report for Lunar
Resolved
Incident has been resolved and everything is back to normal.
Posted May 31, 2022 - 20:57 CEST
Identified
We are currently experiencing some challenges with transfers. You can also expect a small delay with receiving and sending payments.
We're sorry for the inconvenience, and we'll keep posting information on this site.
Posted May 31, 2022 - 20:05 CEST