Card information may not be available in the app
Resolved·Degraded performance

The problem has been successfully resolved, and all customers can once again access their card information in the app.

Tue, Oct 10, 2023, 02:17 PM
(1 year ago)
·
Affected components
Updates

Resolved

The problem has been successfully resolved, and all customers can once again access their card information in the app.

Tue, Oct 10, 2023, 02:17 PM

Identified

We have identified the issue and our third-party card provider is working on a fix.

Tue, Oct 10, 2023, 08:18 AM(5 hours earlier)
Powered by