Problems with accessing account and usage of card
Resolved·Full outage

We have now solved the issue, and everything is working again.

Fri, May 26, 2023, 10:36 AM
(1 year ago)
·
Affected components
Updates

Resolved

We have now solved the issue, and everything is working again.

Fri, May 26, 2023, 10:36 AM

Identified

We are currently experiencing issues with customers unable to use their cards and log in to their Lunar app.

Our technical department is already on the case and is working to resolve the issue.

Fri, May 26, 2023, 09:45 AM(50 minutes earlier)
Powered by