MITID issues
Resolved·Degraded performance

MITID has successfully resolved the issue and has returned to its usual operational state.

Fri, Feb 2, 2024, 08:46 AM
(1 year ago)
·
Affected components
Updates

Resolved

MITID has successfully resolved the issue and has returned to its usual operational state.

Fri, Feb 2, 2024, 08:46 AM

Identified

MITID is currently encountering some technical difficulties. Therefore, Android users might be prompted to scan a QR code on the same device as the MITID app, making it temporarily impossible to proceed.

Rest assured, MITID is actively addressing and working to resolve the issue.

Wed, Jan 31, 2024, 06:47 AM(2 days earlier)
Powered by