Currently unavaiable
Incident Report for Lunar
Resolved
This incident has been resolved.
Posted Dec 06, 2023 - 15:01 CET
Update
This incident has been resolved.
Posted Dec 06, 2023 - 15:01 CET
Investigating
We're currently facing difficulties with our phone line, making it temporarily unavailable for contact at the moment. Rest assured, we are actively working to resolve this issue.

We appreciate your understanding as we work to address the situation.
Posted Dec 06, 2023 - 12:33 CET
This incident affected: 🧑‍🚀 Customer support (☎️ Phone).