Norwegian customer support is having problems with their phone connection
Resolved·Full outage

This incident has been resolved.

Fri, Feb 17, 2023, 03:34 PM
(2 years ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Fri, Feb 17, 2023, 03:34 PM

Identified

The issue has been identified and a fix is being implemented.

Fri, Feb 17, 2023, 02:36 PM(57 minutes earlier)

Investigating

Our Norwegian customer service is currently having problems with the phone connection, therefore it will not be possible to contact them at the moment.

Fri, Feb 17, 2023, 01:54 PM(42 minutes earlier)
Powered by