Resolved
Issue have been resolved. You are now able to see your transactions in the app.
Identified
We are currently experiencing problems with loading and displaying transactions within the app. You will still be able to receive transactions.
Some user have mistakenly received an email that they have ordered a premium card. The email can safely be ignored.