irregularities on the mobile network
Resolved·Full outage

This incident has been resolved.

Wed, Dec 20, 2023, 08:00 PM
(1 year ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Wed, Dec 20, 2023, 08:00 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Wed, Dec 20, 2023, 07:59 PM

Identified

Our customer service cannot be reached by phone due to irregularities on the mobile network. We recommend that you reach out to us through the chat or try again later.

Wed, Dec 20, 2023, 02:31 PM(5 hours earlier)

Identified

Our phone provider has informed us that they have escalated the issue and are actively working to resolve it. Currently, we are still unable to receive calls on the phone line in Denmark. We appreciate your patience as we work towards a solution.

Wed, Dec 20, 2023, 12:57 PM(1 hour earlier)

Investigating

We are currently experiencing issues with our phone line in Denmark. We're actively looking into this issue and appreciate your patience.

Wed, Dec 20, 2023, 11:33 AM(1 hour earlier)
Powered by