Monitoring
Nets is still experiencing issues, and we see card payments still failing.
We continue to monitor their status and will provide an update once more information becomes available.
Investigating
We are currently experiencing an issue where card payments are being declined.
This is caused by a problem with Nets that we rely on to handle card transactions.
Our team is monitoring the situation closely. This is not caused by anything on our end.
We are monitoring the situation and will update once more information becomes available.