Technical Issues Affecting Card Payments
Resolved·Degraded performance

We have now resolved this issue.

Card payments are fully operational again, and any charges from previously failed transactions have been automatically refunded to customers' accounts.

Thu, Jul 31, 2025, 09:05 AM
(1 month ago)
·
Affected components
Updates

Resolved

We have now resolved this issue.

Card payments are fully operational again, and any charges from previously failed transactions have been automatically refunded to customers' accounts.

Thu, Jul 31, 2025, 09:05 AM

Investigating

We are currently experiencing technical issues, which unfortunately means that some card payments may be declined in physical stores and online shops.

If your payment has been declined but the amount has been reserved on your account, the funds will automatically be released after a shorter period.

We are working on a solution and will keep you updated once we have more information available.

Thu, Jul 31, 2025, 07:44 AM(1 hour earlier)
Powered by