Issues with our phone system
Resolved·Full outage

We have identified the root cause of the issue and applied a fix. Following this, connectivity to our original phone number has been successfully restored.

All systems are now fully operational, and services have returned to normal.

We apologize for the downtime.

Wed, Jul 30, 2025, 09:13 AM
(1 month ago)
·
Affected components
Updates

Resolved

We have identified the root cause of the issue and applied a fix. Following this, connectivity to our original phone number has been successfully restored.

All systems are now fully operational, and services have returned to normal.

We apologize for the downtime.

Wed, Jul 30, 2025, 09:13 AM

Investigating

We are continuing to investigate the issue, but the exact cause has not yet been identified.

In the meantime, we have established a temporary phone number for you to reach our customer support team: +45 78 71 40 30.

(Please note that this is only a temporary number, and we do not recommend saving it.)

Wed, Jul 30, 2025, 07:55 AM(1 hour earlier)

Investigating

We are currently experiencing issues with our phone system that are preventing customers from reaching us.

Our team is actively investigating the problem, and we will keep you updated as we make progress.

Wed, Jul 30, 2025, 07:24 AM(30 minutes earlier)
Powered by