Issues with our phone system
Resolved·Degraded performance

The issue has now been identified and resolved.

We experienced two brief network disruptions and are looking into these.

We apologize for any inconvenience.

Tue, Jul 1, 2025, 11:19 AM
(5 days ago)
·
Affected components
Updates

Resolved

The issue has now been identified and resolved.

We experienced two brief network disruptions and are looking into these.

We apologize for any inconvenience.

Tue, Jul 1, 2025, 11:19 AM

Investigating

We are still experiencing issues, but we can see minor improvements. We are investigating the problem and will keep you updated as we make progress.

Tue, Jul 1, 2025, 10:43 AM(36 minutes earlier)

Investigating

We are experiencing an issue with our phone system, which is affecting our ability to handle some incoming calls.

Our team is actively investigating the problem, and we will keep you updated as we make progress.

Tue, Jul 1, 2025, 10:01 AM(42 minutes earlier)
Powered by