Issues with our phone system
Resolved·Full outage

A fix has been successfully implemented, and all systems are fully operational.

Mon, Jun 2, 2025, 06:00 PM
(1 week ago)
·
Affected components
Updates

Resolved

A fix has been successfully implemented, and all systems are fully operational.

Mon, Jun 2, 2025, 06:00 PM

Identified

We’ve identified the root cause of the issue and are currently working on a fix.

While our phone lines will close at 17:00 as scheduled, we will continue to share updates here as we make progress.

Mon, Jun 2, 2025, 03:07 PM(2 hours earlier)

Investigating

We’re currently unable to receive phone calls due to an issue with one of our service providers.

Our team is actively working to resolve the problem, and we’ll share updates as soon as we have more information.

Mon, Jun 2, 2025, 02:29 PM(38 minutes earlier)
Powered by