Swish is currently experiencing issues
Resolved·Full outage

Swish has confirmed that the issue has been resolved, and we've observed that traffic levels have returned to normal.

Thu, May 22, 2025, 02:20 PM
(3 weeks ago)
·
Affected components
Updates

Resolved

Swish has confirmed that the issue has been resolved, and we've observed that traffic levels have returned to normal.

Thu, May 22, 2025, 02:20 PM

Identified

Swish has now identified the issue and is working on resolving it.

We will continue to monitor the situation and keep you updated.

Thu, May 22, 2025, 01:04 PM(1 hour earlier)

Investigating

The issue affecting Swish services is still under investigation by Swish.

Our team continues to monitor their status for the latest updates.

Thu, May 22, 2025, 12:41 PM(23 minutes earlier)

Investigating

Swish is currently experiencing an issue that is affecting payments.

We are closely monitoring the situation and will provide an update as soon as we have more information.

Thu, May 22, 2025, 11:27 AM(1 hour earlier)
Powered by