Swish is currently experiencing issues
Resolved·Partial outage

We can confirm that traffic has returned to normal and the issue has been resolved.

Sat, May 17, 2025, 10:21 AM
(1 month ago)
·
Affected components
Updates

Resolved

We can confirm that traffic has returned to normal and the issue has been resolved.

Sat, May 17, 2025, 10:21 AM

Monitoring

Swish has reported that the issue is resolved, and we’re seeing traffic return to normal.

We’ll continue monitoring the situation for a while before closing the incident.

Sat, May 17, 2025, 10:05 AM(15 minutes earlier)

Identified

Swish has identified the cause but is still experiencing issues.

We’ll keep you updated as soon as we receive more information.

Sat, May 17, 2025, 09:53 AM(11 minutes earlier)

Investigating

Swish is currently experiencing an issue that is affecting payments.

We are closely monitoring the situation and will provide an update as soon as we have more information.

Sat, May 17, 2025, 09:39 AM(13 minutes earlier)
Powered by