Swish is currently experiencing issues
Resolved·Partial outage

Swish reported the issue as resolved around 22:00 last night, but our data shows that services weren’t fully restored until around 08:17 AM this morning.

Swish is now back to normal operations and is no longer experiencing any issues.

Wed, May 7, 2025, 06:17 AM
(4 months ago)
·
Affected components
Updates

Resolved

Swish reported the issue as resolved around 22:00 last night, but our data shows that services weren’t fully restored until around 08:17 AM this morning.

Swish is now back to normal operations and is no longer experiencing any issues.

Wed, May 7, 2025, 06:17 AM

Investigating

Swish is currently experiencing a major ongoing disruption in their system.

As a result, Swish may not work as expected for customers and could potentially fail.

We are monitoring the situation on Swish’s site and will keep you updated as soon as more information becomes available.

Tue, May 6, 2025, 08:04 PM(10 hours earlier)
Powered by