Swish top-up is currently unavailable
Resolved·Degraded performance

We’ve now implemented a fix and are seeing top-ups across all payment methods going through again.

We apologize for the downtime.

Tue, May 6, 2025, 08:24 AM
(1 month ago)
·
Affected components
Updates

Resolved

We’ve now implemented a fix and are seeing top-ups across all payment methods going through again.

We apologize for the downtime.

Tue, May 6, 2025, 08:24 AM

Identified

We are currently experiencing an issue with Swish Top-ups.

Our team has identified the issue and is working on a fix.

In the meantime, customers may experience issues when using this service until the fix is applied.

Tue, May 6, 2025, 06:46 AM(1 hour earlier)
Powered by