Issues with our phone system
Resolved·Partial outage

Our phone provider has resolved the issue, and everything is now fully operational again.

We apologize for the downtime and will continue working on improving this specific area.

Thank you for your patience.

Wed, Mar 26, 2025, 10:28 AM
(1 week ago)
·
Affected components
Updates

Resolved

Our phone provider has resolved the issue, and everything is now fully operational again.

We apologize for the downtime and will continue working on improving this specific area.

Thank you for your patience.

Wed, Mar 26, 2025, 10:28 AM

Monitoring

Our phone provider has now taken steps to address the issue, and it appears to have resolved the issue.

We will continue to monitor the situation over the next hour before taking any final steps.

Wed, Mar 26, 2025, 09:21 AM(1 hour earlier)

Investigating

Our phone provider is currently experiencing issues, allowing customers to call us, but preventing us from answering. As a result, we have temporarily closed our phone lines until the issue is fully resolved.

We will keep you updated as we make progress.

Wed, Mar 26, 2025, 08:29 AM(52 minutes earlier)
Powered by