Issues with our phone system
Resolved·Degraded performance

Our external phone provider has resolved the issue, and everything has now returned to normal operations.

We apologize for the downtime and any inconvenience caused.

Fri, Mar 7, 2025, 10:28 AM
(3 weeks ago)
·
Affected components
Updates

Resolved

Our external phone provider has resolved the issue, and everything has now returned to normal operations.

We apologize for the downtime and any inconvenience caused.

Fri, Mar 7, 2025, 10:28 AM

Monitoring

While we await a resolution from our external phone provider, we're happy to report that employees can now take calls again, and operations are returning to normal.

We will still monitor the situation closely and take further action if necessary.

Fri, Mar 7, 2025, 10:09 AM(18 minutes earlier)

Investigating

Our external phone provider is currently experiencing technical issues, which may prevent some of our employees from answering calls. We are in close communication with them and working to resolve the issue as quickly as possible.

In the meantime, you're always welcome to reach out to us through the app for assistance.

Fri, Mar 7, 2025, 09:56 AM(13 minutes earlier)
Powered by