MITID is currently expericing issues
Resolved·Partial outage

MITID has just reported that they’ve resolved the issue, and we can see that customers are going through successfully again.

Fri, Feb 28, 2025, 05:34 AM
(1 month ago)
·
Affected components
Updates

Resolved

MITID has just reported that they’ve resolved the issue, and we can see that customers are going through successfully again.

Fri, Feb 28, 2025, 05:34 AM

Identified

As MITID hasn't provided any updates yet, we’re seeing a significant improvement in customers completing the flow.

We will continue monitoring the situation and keep you posted as it develops.

Fri, Feb 28, 2025, 05:27 AM

Investigating

MITID is currently experiencing issues, which means that anything requiring approval through MITID could potentially fail. We are closely monitoring the situation and will keep you updated as we receive more information.

Fri, Feb 28, 2025, 05:09 AM(17 minutes earlier)
Powered by